System Requirements

The Laboratory Management Toolbox uses rich media content and requires appropriate plugins for both your web browser and computer for correct viewing. Please follow the steps below to ensure that you have the required plugins. Note that this page may take some time to display all the information.

Hardware (minimum requirements)

IBM compatible computer with:

OR

Macintosh equivalent.

Software (minimum requirements)

You may have a more enjoyable user experience and/or increased performance if using later versions of software than those listed below.

Flash 6 player

If you can see the sample file to the left you have the Flash 6 player or later installed!

You will need this plugin to view certain aspects of the learning unit content.

If you cannot see this Flash sample please download the plugin from Macromedia.


 

Internet Explorer 5

Internet Explorer 5

You can use this web browser to view the Laboratory Management Toolbox. If you do not have Internet Explorer download it from Microsoft.


 

Netscape 4.7

Netscape 4.7

You can use this web browser to view the Laboratory Management Toolbox. If you do not have Netscape Navigator download it from Netscape.


 

Microsoft Word

Microsoft Word

You will need this software to be able to open Microsoft Word documents that are used extensively throughout the Laboratory Management Toolbox. Alternatively use other software capable of opening the Microsoft Word format (.doc).


 

Microsoft Excel

Microsoft Excel

You will need this software to be able to open Microsoft Excel spreadsheet documents that are used occasionally throughout the Laboratory Management Toolbox. Alternatively use other software capable of opening the Microsoft Excel format (.xls).